На старт внимание wifi

Тема в разделе "Arduino & Shields", создана пользователем schel4ok, 10 окт 2020.

  1. schel4ok

    schel4ok Нуб

    У меня давно лежит набор «интернет вещей». Пару лет назад я что-то экспериментировал, а потом забросил. Сейчас решил опять разобраться.
    И не получается воспроизвести самый первый эксперимент из конспекта Интернет вещей
    Соединяю Arduino UNO с модулем wifi как в конспекте.
    iot.JPG
    TX -> 1
    RX -> 0
    V ->5V
    G -> GND
    На ардуино Reset -> GND (это вообще не понял зачем).

    При этом в конспекте не указано надо ли как-то предварительно прошить Ардуино и wifi модуль. На всякий случай перед соединением wifi модуля прошил Ардуино пустым скетчем.
    Код (C++):

    void setup()
    {}
    void loop()
    {}
     
    Теперь открываю монитор порта. По умолчанию там скорость 115200 бод.
    Ввожу AT (на всякий случай английскими буквами) -> Монитор пустой
    Поменял скорость на 9600. Опять ввожу АТ и в мониторе выводится
    Код (C++):
    AT

    ERROR
    После этого я посмотрел, что если воткнуть wifi модуль в Troyka Slot Shield, то соединение будет другое
    TX -> 0
    RX -> 1
    V ->5V
    G -> GND
    troyka-wi-fi_scheme_troyka-slot-shield.png

    Попробовал соединить так и снова открыл монитор порта. Скорость 115200.
    В порту появилась надпись.
    ???rial init OK
    Ввёл АТ и ничего не увидел.
    Поменял скорость на 9600 и в мониторе появился бесконечный вывод вопросительных знаков.
    На ввод команд не реагирует.

    Что делать надо?
     
  2. a1000

    a1000 Гик

    А конспект внимательно читали?
    "В этом случае ATmega неактивен, работает только USB-UART преобразователь (адаптер)."
    Вот вам сразу и ответ на следующий вопрос
    Микроконтроллер работать не будет, по барабану что в нём залито.
    А как по другому. Читаем конспект
    "Набери в командной строке большими буквами в латинской раскладке «AT» и нажми Enter."
    И проверьте
    "Выстави параметр «Both NL & CR», это поможет тебе корректно отправлять AT-команды и видеть ответы на них."
     
  3. schel4ok

    schel4ok Нуб

    Both NL & CR стоят по умолчанию но либо вообще нифига нет ответа либо ERROR
     
  4. b707

    b707 Гуру

    Я вас обрадую, ERROR - это хорошо, это означает что все соединено верно, модуль получает команды и отвечает. Только вот команды ваши ему чем-то не нравятся.

    Попробуйте поменять параметр конца строки (это там где "NL+CR") на другой (попробуйте все варианты)