Не прошивается...

Тема в разделе "Arduino & Shields", создана пользователем zserg, 23 июн 2016.

  1. zserg

    zserg Нерд

    Всем привет!

    Купил китайскую LilyPad на atmega 328. Подключил через FTDI от adafruit (родной) - всё опознаётся, начинает работать штатно прошитый blink. Но при попытке что-то прошить самому выдаётся такое:

    Код (C++):

    /usr/share/arduino/hardware/tools/avrdude -C/usr/share/arduino/hardware/tools/avrdude.conf -v -v -v -v -patmega328p -carduino -P/dev/ttyUSB2 -b57600 -D -Uflash:w:/tmp/build7372800102049243046.tmp/Blink2.cpp.hex:i

    avrdude: Version 6.0.1, compiled on Oct 21 2013 at 15:55:32
             Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
             Copyright (c) 2007-2009 Joerg Wunsch

             System wide configuration file is "/usr/share/arduino/hardware/tools/avrdude.conf"
             User configuration file is "/home/serg/.avrduderc"
             User configuration file does not exist or is not a regular file, skipping

             Using Port                    : /dev/ttyUSB2
             Using Programmer              : arduino
             Overriding Baud Rate          : 57600
    avrdude: Send: 0 [30]   [20]
    avrdude: Send: 0 [30]   [20]
    avrdude: Send: 0 [30]   [20]
    avrdude: ser_recv(): programmer is not responding
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
    avrdude: Send: 0 [30]   [20]
    avrdude: ser_recv(): programmer is not responding
    avrdude: stk500_recv(): programmer is not responding
    avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
    avrdude: Send: 0 [30]   [20]
    Плата в IDE выбрана нужная, проверил. Пробовал с зажатым reset-ом (как только моргает TX на адаптере отпускаю) - не помогает. Версия IDE - 1.0.5.

    Может проблема в загрузчике? Как можно сбросить плату и прошить загрузчик новый? Или ещё какое решение есть?