Ошибка в WiFi модуле

Тема в разделе "Проводная и беспроводная связь", создана пользователем Arduino_man, 2 янв 2018.

Метки:
  1. Arduino_man

    Arduino_man Гик

    Здравствуйте!
    Есть набор "Интернет вещей" от Амперки (дополнение для Матрешки). При работе с первым экспериментом (изучение WiFi-модуля) сервер корректно поднимается командой AT+CIPSERVER=1,80 но не отключается указанной в буклете командой AT+CIPSERVER=0,80. Как решить эту проблему?
    Заранее спасибо за помощь!
     
  2. Arduino_man

    Arduino_man Гик

    Похоже, никому не интересно разобраться, почему в заводской прошивке модуля находятся ошибки. Очень жаль. Спасибо за помощь!
     
  3. ИгорьК

    ИгорьК Давно здесь

    Не интересно, потому что, наверно, уже есть новая прошивка: http://espressif.com/en/support/download/at?keys=&field_type_tid[]=14
    и к ней, наверняка, есть набор АТ-команд и пример их применения.
     
    Arduino_man нравится это.
  4. Arduino_man

    Arduino_man Гик

    Интересно, почему модуль поставляется с бракованной прошивкой?
    Не подскажете, как перепрошить модуль?
     
  5. ИгорьК

    ИгорьК Давно здесь

    Я не уверен что прошивка "бракованная".
    На тему перепрошивки есть у Амперки инструкция где-то, поищите. Точно есть.
     
    Arduino_man нравится это.
  6. Arduino_man

    Arduino_man Гик

    А мне так очень кажется. Либо заводская прошивка бракованная, либо в "Продолжении конспекта хакера" ошибка. Может быть, сервер отключается командой AT+CIPSERVER=2,80, но вряд ли. Я склоняюсь к плохой прошивке.
    В любом случае буду перепрошивать модуль, т.к. уже программировал его.
     
  7. DIYMan

    DIYMan Гуру

    Я так понимаю, что AT+CIPMUX=1 перед запуском сервера сделана? Попробуйте после посылки AT+CIPSERVER=0,80 послать AT+CIPMUX=0
     
  8. Arduino_man

    Arduino_man Гик

  9. ИгорьК

    ИгорьК Давно здесь

  10. DIYMan

    DIYMan Гуру

  11. Arduino_man

    Arduino_man Гик

    Нет. Работаю с программированием модуля. Прошивку сменю.