Помогите разобраться с кодом

Тема в разделе "Arduino & Shields", создана пользователем F0XYK, 22 окт 2018.

  1. F0XYK

    F0XYK Нуб

    Здравствуйте народ,
    помогите разобраться с кодом. Ситуация в том, что при подключении внешнего питания к Arduino nano v3 (5В) не выполняется код, залитый в ардуинку.
    Лампа питания горит зеленым, но по светодиоду и по реле, которое подключено к одному из контактов, ничего не происходит. При нажатии кнопки ресет, устройство начинает работать нормально.
    Суть устройства: измеряя напряжение на ногах А3 и А5, ардуинка отключает на 7 секунд реле и потом его включает опять. По типу домофона.
    В чем может быть проблема?
    Занятно то, что от USB от компа все работает корректно. Но если подключить к павербанку, то проблема остается.

    ПРОБЛЕМУ РЕШИЛ:
    решение заключается в подтяжке контакта RESET к земле через 10К сопротивление.
     
    Последнее редактирование: 22 окт 2018
  2. BAR__MEN

    BAR__MEN Иномирянин Команда форума

    А прмчпр тут помощь с кодом? :confused:
     
  3. F0XYK

    F0XYK Нуб

    Думал проблема в коде, хотя вроде все чисто по коду. На многих форумах писали что скорее всего дело в коде, но я разобрался с этим через сопротивление. Если питать голые чипы, без обвязки, рекомендуют подтягивать ресет через 10к. Вот и решил сделать так же. Результат вы уже знаете.
     
  4. BAR__MEN

    BAR__MEN Иномирянин Команда форума

    Да я не об этом.
    У вас в названии темы просьба посопо с кодом, а в самом сообщении совсем другое,..
     
  5. Mitrandir

    Mitrandir Гуру

    Так тело изменилось с момента создания.
     
  6. BAR__MEN

    BAR__MEN Иномирянин Команда форума

    А пояпоч бы и заголовок не поправить?