Помогите с lcd 1602 и I2C [Решено]

Тема в разделе "Микроконтроллеры AVR", создана пользователем nevikat, 28 янв 2018.

  1. nevikat

    nevikat Нуб

    Здравствуйте! У меня проблема: я подключил дисплей 1602 через I2C к Ардуино и у меня всё хорошо работало. Но вдруг подсветка дисплея пропала. Чтобы я ни делал, ничего не помогает. Может кто-то сталкивался с этим? Помогите, пожалуйста!
     
  2. Vladimir71

    Vladimir71 Нерд

    Для начала нужно видеть схему подключения подсветки, мало ли чего там наварочено. Ну а так, подать питание на подсветку и проверить работоспособность.
     
  3. nevikat

    nevikat Нуб

    Да, я был дурак. Сейчас подал питание на подсветку и всё заработало. Проблема скорее всего в I2C. Я если яркость ставлю меньше максимальной, у меня всё заливает синим. А так, спасибо!
     
  4. Vladimir71

    Vladimir71 Нерд

    Шина и прошивка ни какого отношения к подсветке не имеет. Подсветка это как отдельное устройство.
     
  5. nevikat

    nevikat Нуб

    Я понимаю. Просто я имею ввиду то, что на шине где-то отошёл контакт. В интернете много случаев, когда что-то с ней не то происходит.
     
  6. Vladimir71

    Vladimir71 Нерд

    ну если что-то с отоброжение информашии, то возможно что-то и отошло, это нужно видеть.
     
  7. nevikat

    nevikat Нуб

    Вот вот. Я о том же.
    Но проблему я решил. Всем спасибо за участие!
     
  8. Vladimir71

    Vladimir71 Нерд

    Поздравляю, но интересен результат, т.е. причину.
     
  9. nevikat

    nevikat Нуб

    Я же говорю, точно причину не знаю. Скорее всего, криво припаял или где-то отошёл контакт.