Постоянно мигает светодиод L и не загружаются скетчи

Тема в разделе "Arduino & Shields", создана пользователем HellHoma, 30 июл 2019.

  1. HellHoma

    HellHoma Нуб

    Приобрёл недавно Iskra Neo (arduino leonardo). Долгое время загружал скетчи, всё было нормально. В один момент плата перестала загружать любые скетчи и при этом на ней постоянно мигает светодиод L, как при включении или перезагрузке платы. В диспетчере устройств появляется только бутлоадер, затем пропадает, не оставляя COM-порта. Пытался восстанавливать загрузчик по этой статье. Blink загружает один раз, но потом всё опять слетает и беспрерывное мигание продолжается. В чём может быть проблема? Скетч проверял, он точно не виноват.
     
  2. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    Это болезнь, из-за которой нужно успеть залить скетч за пару секунд после перезагрузки платы :)
     
  3. parovoZZ

    parovoZZ Гуру

    Не понял, что восстанавливать, если:
    ???
    К тому же это его штатная работа на леонарде.
     
  4. Airbus

    Airbus Радиохулиган Модератор

    Это как?Бутлоадер не может появятся и пропадать.На это способен только СОМ порт устройства.
    Нафига?поздравляю-вы его убили наповал.
     
  5. Daniil

    Daniil Гуру

    При подключении леонардо, появляется один ком-порт на 8-10 сек, а потом пропадает и на его место появляется другой. Так и должно быть. Ничего не перепутали?
     
    BAR__MEN, Max_dk и Airbus нравится это.
  6. Max_dk

    Max_dk Нерд

    Попробуй USB шнурок поменять, не включай леонардо через USB хаб - включай напрямую в ПК.
     
  7. parovoZZ

    parovoZZ Гуру

    Да. Но только леонарда. И там не ком порт, кстати.
     
  8. Airbus

    Airbus Радиохулиган Модератор

    Эмулятор.он же виртуальный СОМ порт.
     
    Max_dk, Daniil и BAR__MEN нравится это.