РЕШЕНО Проблема работы ик приемника

Тема в разделе "Arduino & Shields", создана пользователем Illaise, 23 дек 2020.

  1. Illaise

    Illaise Нерд

    Всем привет. Использую Arduino UNO Wi-Fi Rev2. Цель моего проекта такая - при нажатии на пульт ардуино (https://arduino.ua/prod2307-ik... ya-ardyino) ИК приемник ( Датчик VS1838B, модуль KY-022) декодирует сигнал. Затем преобразуем кейкоды от ардуино в кейкоды пульта (например, самсунг) и ИК передатчиком отправляем их на телевизор.
    Проблема возникла на этапе приема сигнала COM порт не выводит никакой информации от приемника, пробовал разные скетчи, например:
    Код (C++):
    #include <IRremote.h>
    int input_pin = 10; //set D10 as input signal pin
    IRrecv irrecv(input_pin);
    decode_results signals;
    void setup()
    {
    Serial.begin(9600);
    irrecv.enableIRIn(); // enable input from IR receiver
    }
    void loop() {
    if (irrecv.decode(&signals)) {
    Serial.println(signals.value, HEX);
    irrecv.resume(); // get the next signal
    }
    }
    Схема подключения во вложении

    Пробовал делать по разным видео, по типу



    Брал код из них, пробовал разные пины.
    Подключал ИК приемник в порт RX, загружал пустой скетч и смотрел, будет ли в порту какая-то реакция на нажатия пульта - результат негативный.
    В работе с ардуино я новичок, буду очень благодарен за помощь.
     

    Вложения:

    Последнее редактирование: 23 дек 2020
  2. KindMan

    KindMan Гик

    Вставьте код согласно правилам. Приложите конкретно вашу схему подключения на текущий момент и модель ИК приёмника.
     
    NikitOS нравится это.
  3. Illaise

    Illaise Нерд

    Спасибо за замечания, исправил.
     
  4. рокки1945

    рокки1945 Гуру

    Приветствую - Сначала надо посмотреть работает ли у Вас serial - отладку с этого надо начинать просто возьмите пример сериал и выведите через print что-нибудь - "Hello! ".
     
    Illaise нравится это.
  5. ZAZ-965

    ZAZ-965 Гуру

    Illaise нравится это.
  6. Illaise

    Illaise Нерд

    Решил проблему, спасибо! Дело было в некачественном кабеле USB A -> B