Пропадает сеть Raspberry pi 3

Тема в разделе "Raspberry Pi", создана пользователем galemus, 10 окт 2017.

  1. SergeiL

    SergeiL Гик

    Как я понимаю, если бы была проблема с DHCP, то не работали бы вновь подключенные устройства, а те, которые были подключены до малины, нормально бы работали.

    На любой машине в сети запустить командную строку и проверить что происходит:
    • Ipconfig /all (до и после подключения малины и появления проблемы)
    • ping ip_адрес_роутера
    • ping ip_адрес_другого_устройства_в_LAN
    • ping www.ya.ru
    • tracert www.ya.ru
     
    ИгорьК нравится это.
  2. ИгорьК

    ИгорьК Победитель модулей

    Не...

    "Доктор сказал в морг, значит в морг":
     
  3. galemus

    galemus Нерд

    проблема в том, что после подключения малины, отваливаються подключение всех устройств к wifi роутеру, зато малина подключаться к роутеру, получает ip адресс выданный роутерем(адресс малины 192.168.10.110, у роутера 192.168.10.1), инета правда нет у малины

    после моих капаний , у видел в ifconfig у lo значение mtu стоит 65536(у wlan0 mtu1500) может здесь ответ
     
  4. SergeiL

    SergeiL Гик

    Попробуйте ставить ПО не подряд а с выдержкой времени.
    Тогда можно будет понять, что влияет на проблему.
     
  5. galemus

    galemus Нерд

    я так думаю вся проблема в обновлении. Когда я ставлю образ на флешку и включаю у меня все нормуль. Как только делаю sudo apt-get update и sudo apt-get upgrade, появляеться конфликты. Найти что обновление меняет??

    И вообще может я что -то ни так делаю.
    Что я хочу в итоге:
    1.Есть домашняя сеть с теликами, компами. Все это соединено к WIFI Роутеру. IP у всех динамическое.
    2.Хочу сделать малину сервером для личных нужд, чтобы к ней можно было подключиться с внешнего инета. Провайдер мне выделил статический IP (83.x.x.x)
    3.Ставлю образ на флешку(SDcard), подключаю малину к сети по WIFI. Все работает
    4.Включаю SSH и VNC.Делаю на WIFI роутере настройки чтобы малина получала статический внутрений адресс по MAC.И подключаюсь с другого компа в сети через VNC viwer.
    5.Далее делаю sudo apt-get update и sudo apt-get upgrade
    6.Далее ставлю сервак Apache
    7.Далее ставлю php
    8.Далее ставлю Mysql
    9.Все работает(захожу на свою стартовую страницу с телефона(другой инет))
    Прикол в том что радость моя заканчиваеться в среднем через минут 30
    Сеть начинает тупить и отключаться у всех устройств
     
    Последнее редактирование: 11 окт 2017
  6. Igor68

    Igor68 Гик

    А что в /etc/network/interfaces? Имеется ввиду содержимое... и что показывает netstat -nlta?
    А nmap localhost что гласит... если установлен конечно... но и netstat хватит.
     
    Последнее редактирование: 11 окт 2017
  7. galemus

    galemus Нерд

    Ок вечером отпишусь

    Хожу по форумам, http://raspberrypi.ru/forum/topic/691/может тупо питания не хватает. У меня конечно блок на 2А. Попробую другой подключить...
     
    Последнее редактирование: 11 окт 2017
  8. ИгорьК

    ИгорьК Победитель модулей

    Это я Вам и хотел сказать. Третья Малина зело привередлива по питанию. Блок, от которого вторая плюс работала на ура питать третью не смог.
    Долго бился с ней - тоже думал неисправна.

    Ну а так - устанавливайте по одной программе в день и наблюдайте что вносит бардак.

    И еще - последняя версия распиан, все таки, не всегда хорошо стыкуется со старыми пакетами.
     
    Последнее редактирование: 11 окт 2017
  9. galemus

    galemus Нерд

    а сколько ей надо ,3А что ли??
     
  10. ИгорьК

    ИгорьК Победитель модулей

    Да надо ей по даташиту 2 как и старой. Но... Самсунговский 2а родной бп - работает. А обычный, из офиса МТС на 2 - нет. Кто врет, кто правду говорит...
     
  11. galemus

    galemus Нерд

    Купил новый на 2.4 амепера все то же самое. В итоге решил заново ставить ПО поэтапно и смотреть что будет....
     
    Последнее редактирование: 11 окт 2017
  12. galemus

    galemus Нерд

    Так ну что господа
    1.Я заново поставил на флешку https://downloads.raspberrypi.org/raspbian/images/raspbian-2017-07-05/ Jessie
    2.Включил VNC,ssh
    3.Статическое IP поставил не на роуторе, а на малине в настройках сети wlan0
    4.Удаленный доступ теперь работает по всему миру.
    5.netstat -nlta показывает:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 0.0.0.0:5900 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp 0 0 192.168.x.115:5900 217.118.83.184:50209 ESTABLISHED
    tcp 0 0 127.0.0.1:43495 127.0.0.1:50098 ESTABLISHED
    tcp 0 0 127.0.0.1:50098 127.0.0.1:43495 ESTABLISHED
    tcp6 0 0 :::5900 :::* LISTEN
    tcp6 0 0 :::22 :::* LISTEN

    6. Прошло 20 часов зависаний не наблюдается
    PS.Может из-за того что стоит новый блок питания 2.4А.(Мысли в слух)
     
    Последнее редактирование: 12 окт 2017
  13. galemus

    galemus Нерд

    вопрос??
    какой сервер лучше для python + mysql.И как правельно его поставить???

    Поставил Apaсhe
    sudo apt-get install apache2 -y

    Пока полет нормальный
     
    Последнее редактирование: 12 окт 2017
  14. Igor68

    Igor68 Гик

    Ну нормально SSH на месте и VNC на месте... похоже у Вас не "подняты реальные иксы" если разрешил по 5900, а не по 5901 и т.д. Сборка системы такая... ну это не важно.
     
  15. Igor68

    Igor68 Гик

    После apache и mysql ждите добавления открытых портов 80 и 3306 по netstat -nlta.
    Все настройки mysql введёте при первом запуске... . Впрочем Вы знаете как, Вы же упорно хотите работать с этой базой. Я поставил себе... и не могу понять зачем mysql мне... не по моему профилю всё-ТАКИ.
     
    Последнее редактирование: 13 окт 2017