питание ардуино.

Тема в разделе "Arduino & Shields", создана пользователем Mitrandir, 21 апр 2014.

  1. Tomasina

    Tomasina Сушитель лампочек Команда форума

    можно. Питание переключается автоматически, от входа с наибольшим напряжением.
     
  2. Unixon

    Unixon Оракул

    Не совсем так. На известных схема реализовано переключение при Vin/2 > 3.3V.
     
  3. Borsoft

    Borsoft Нуб

    А от автомобильной бортовой сети кто-нибудь запитывал напрямую? Там до 14,5 вольт. Сильно будет греться?
     
  4. Sparkfire

    Sparkfire Гик

    Насчет греться- вопрос второй, первый вопрос- стабилизировать питание от перепадов.
     
  5. Mestniy

    Mestniy Гуру

    Мажно стаб купить. Или самому собрать.))
     
  6. Vad33

    Vad33 Капитан-оригинал

    Через LM7809
     
  7. kvv213

    kvv213 Нерд

    Друзья, назрел вопрос.... Собираю схему с Ethernet Shield и кучкой датчиков (вкупе с MQ-серией). Проблема в том, что при подключении MQ датчиков питания от USB уже не хватает, чтобы запустить Ethernet. Нужно использовать внешний блок питания. Подрубаю 9V 1A блок на вход штырьковый. Не запускается Ethernet даже без подключения MQ.

    По всей видимости на плате стоит совсем слабенький преобразователь, который прям совсем не тянет. И собственно вопрос. Тогда получается беру 5V 5Vin 1A блок питания, подрубаю его к 5V и GND. По всей видимости работать должно. Но если подключить к USB не отключая от 5V? Тогда будет работать?
     
  8. fogary

    fogary Гик

    Сама Arduino от 9 В запускается?

    Так лучше не делать.
     
  9. DIYMan

    DIYMan Гуру

    Почему? Мотивируйте, плз.
     
  10. kvv213

    kvv213 Нерд

    От 9 вольт сама плата запускается, схема включается. Но шилд не стартует и программа зависает.

    Почему не делать и 5вольт на V5in и USB? По идее, эти 5V с 5Vin пойдут через стабилизатор и будут питать и саму плату и выйдут на 5V пин, откуда можно запитать схему.

    PS. Попробовал сегодня запитать схему через 5Vin от 5V USB блока питания на 2А. Хрен. Все тоже самое получается. Ethernet Shield не запускается. Другого у меня нету, чтоб проверить. Светодиоды на нем загораются, но программа зависает на инициализации.
     
    Последнее редактирование: 3 авг 2016
  11. fogary

    fogary Гик

    Посмотрел схему - действительно, был не прав. Приношу извинение, за то что ввел в заблуждение.
     
  12. kvv213

    kvv213 Нерд

    Я уже попробовал - работает. Вернее не работает у меня Ehternet Shield с внешним питанием, по USB все нормуль. При подключении 5Vin + USB ничего не портится, но Ethernet Shield по-прежнему не включается.
     
  13. fogary

    fogary Гик

    Микросхема на шилде - W5100?
     
  14. kvv213

    kvv213 Нерд

    Arduino Uno R3 от RoboDyn. От него же шилд W5100. Питание USB и через шпынек включается в Arduino. На него же воткнут шилд. 5Vin подключается через шилд.
    При любых раскладках кроме подключения через USB шилд не заводится. При попытке нагрузить схему еще 300 мА (два MQ сенсора) шилд не стартует даже если в USB воткнуть 2А.
     
  15. fogary

    fogary Гик

    Т. е. при питании от USB порта ПК - шилд работает? Или, без сенсоров, от USB 2А - то же работает?
     
  16. kvv213

    kvv213 Нерд

    При питании от USB - все работает. Если подключаю USB и мощные сенсоры, то шилд не работает.
    Если подключаю в USB 2А, то все работает без сенсоров. Если подключаю сенсоры, то шилд не работает.

    Пробовал сенсоры на отдельной плате - работают. Подключаются они к аналоговым портам А0, А1 и питанию, поэтому пересекаться с пинами шилда не должны. Примерное суммарное потребление шилд 300 ма, сенсоры 300 ма, свеотдиоды и ардуино 100 ма. Итого порядка 700 ма.
     
  17. fogary

    fogary Гик

    Если от USB (не важно какого) без сенсоров работает, то может не в потреблении дело. Если отключить часть сенсоров, от 5 В будет запускаться?

    Можете замерить напряжение на выходе 5V шилда, при питании от USB и БП 9 В?

    При внешнем питании, кнопку Reset на шилде нажимать не пробовали (подсмотрел здесь)?
     
    Последнее редактирование: 4 авг 2016
  18. kvv213

    kvv213 Нерд

    Попробовал, ситуация непонятная:

    USB 5V 2A => 4.9V
    USB 5V 2A + 1MQ => 4.7V
    USB 5V 2A + 2MQ => 4.5V

    Шпынек 9V 1A => 2.7V
    Шпынек 9V 1A + 1MQ => 2.3V
    Шпынек 9V 1A + 2MQ => 2.0V

    Vin 5V 2A => 3.7V

    Что-то тут мне не нравится....
     
    Последнее редактирование: 4 авг 2016
  19. fogary

    fogary Гик

    Как предположение, шилд берет питание с выхода 5V Arduino UNO. На шилде стоит стабилизатор 5 -> 3.3 В, который питает контроллер W5100. Для работы этого стабилизатора (по описанию) входное напряжение должно быть как минимум на 1.5 В больше выходного, т. е. минимум 4.8 В. У Вас, даже с одним датчиком, напряжение получается ниже и стабилизатор, возможно, просто не работает.

    Вы напряжение 9 В подавали на штыревой разъем платы? На вход "Vin" (+9 В -> Vin; Gnd -> Gnd) не пробовали подавать?
     
  20. kvv213

    kvv213 Нерд

    9V подавал на шпынек, не на Vin. На Vin подавал 5V 2A.