Китайская Arduino UNO

Тема в разделе "Arduino & Shields", создана пользователем DevilOfDeath, 19 июн 2014.

  1. DrProg

    DrProg Вечный нерд

    Подключил, определился и заработал сразу без всяких драйверов. Тестовая мигалка замигала. Windows 10. IDE 1.6.6.
     
    ИгорьК нравится это.
  2. Пушной звер

    Пушной звер Оракул Модератор

    до последнего не верил? ))))
     
  3. DrProg

    DrProg Вечный нерд

    Был готов к установке драйверов и тому подобных танцев с бубнами типа подбору платы в IDE. Но оно принялось сразу как родное, даже подозрительно.
     
    ИгорьК нравится это.
  4. Kopilov

    Kopilov Гик

    Вероятно, маленькая деталька между C5 и C6 рядом с чёрным резистором. На оригинальной Uno примерно такой же.
     
  5. jaxik2

    jaxik2 Нуб

    Так какой вывод? Вот такое UNO не покупать? Или вы нашли китайский драйвер?
     
  6. DrProg

    DrProg Вечный нерд

    На Вынь 7 потребовалось поставить драйвер, Вынь 10 обошлась без драйвера. В остальном все хорошо, разницы с оригиналом пока не вижу.
     
    ИгорьК нравится это.
  7. Пушной звер

    Пушной звер Оракул Модератор

    у неё есть один серьезный недостаток
     
    Последнее редактирование: 15 дек 2015
  8. DrProg

    DrProg Вечный нерд

    Друзьям это глубоко...
     
    ИгорьК нравится это.
  9. toss

    toss Нуб

    Добрый день!
    Есть у меня Arduino UNO R3 ATmega328P CH340, все шилось, все работало. Подключил питание 12 вольт, явно что-то заглючило и больше не могу заливать скетчи, даже стандартные примеры. По коду ошибки нагуглил, что возможно слетел загрузчик из-за перенапряжения. Везде предлагается перепрошить загрузчик.
    Не нашел ниодного примера как прошить загрузчик в Arduino UNO через Arduiono Nano. Подскажите как их соединить для прошивки?
     
  10. Onkel

    Onkel Гуру

    вроде обычно наоборот делают. но сделать можно - только нужно будет снять с пинов nano сигналы icp, это gnd, Vcc,Reset (portc.6), PortB.3- Portb.5, подать на uno, обязательно перерезав линию к PORTC.6 нановского чипа.
    Но вряд ли слетел загрузчик при всем целом, загрузчик - это флеш, у вас сначала все порты поперегорят, а флеш будет целым. Смотрите целость железа, наличие +5 В на чипах, наличие ардуины в листинге железа компа как vcp.
     
  11. Airbus

    Airbus Радиохулиган Модератор

    Нормальное UNO на ХР поставил драйвер без проблем. Скачал отсюда. http://tinyurl.com/qdetwfw Такой переходник тоже работает.
    Как то так http://tinyurl.com/qj4yptt
     
  12. Есть ответ по китайцам.
    Дело было так. Также как и все китайцы мой nano сильно глючил. То виделся, то не виделся, то давал скетч лить, то не давал. В очередном эксперименте я кое-что перепутал и пошел лёгкий дымок. После этого все прекрасно работает и ни разу никаких глюков не было. Все произошедшее натолкнуло на мысль о плохой пропайке. Источник дыма вычислить не удалось. Но по месту происхождения дыма все стрелки падают на линейный стабилизатор напруги.
    Потом повторил эксперимент на такой же ардунане из этой же партии (заказывал 10шт). Дым в этот раз вызвать не удалось. После хорошего прогрева (очень сильно греется линейник) все заработало как часы.
    Думаю, надо в духовочке пожарить платы.

    PS: дрова и осы не причем. Грешу только на линейник и преобразователь.
     
  13. Mestniy

    Mestniy Гуру

    Вывод такой. Покупать надо у проверенных продавцов. Я заказывал ардуины с разных мест и тоже глюки были. Потом неполенился, поседел немого в али. Поиследовал отзывы и репутцию продавцов. И вот уже который раз заказываю ардуино и притензий пока не было.
     
  14. Пушной звер

    Пушной звер Оракул Модератор

    так берите платы где стоят нормальные кварцы, а не керамические.
    да и тот стаб на нано он вообще некуда не годится, питать их надо или через USB или от стабильных 5 вольт.
     
  15. Kopilov

    Kopilov Гик

    Если можно, отпишитесь в теме http://forum.amperka.ru/threads/проверенные-продавцы-клонов-arduino.6243/ у кого именно теперь заказываете.
     
  16. Mestniy

    Mestniy Гуру

  17. Actimele

    Actimele Нуб

    Друзья, прикупил тоже себе китайскую Uno с шилдом LCD 1602.
    Заливаю скетч в нее - всё работает ( выводится hello world и сдвигается в сторону буквы)
    Вытаскиваю USB шнур (пропадает питание с нее) - далее грузится надпись hello world и всё, не двигается. мигает светодиод L на самой уно. Тут же заливаю новый скетч - всё ок. Такое ощущение, что память не держит скетч или происходит циклическая перезагрузка... Что это может быть?
     
    Последнее редактирование: 28 янв 2016
  18. Kopilov

    Kopilov Гик

    Если при этом она питается от батарейки (или дохлого БП) -- вполне возможна просадка по питанию и, как следствие, перезагрузка.
     
    Actimele нравится это.
  19. Actimele

    Actimele Нуб

    Да, действительно. Проблема оказалась в питании через юсб от компьютера - слишком длинный провод видимо, не хватало питания запуститься. От адаптера 220-5в всё работает.
     
  20. Kosmich

    Kosmich Нуб

    Подскажите пожалуйста. Вот у меня тоже такая плата
    [​IMG]
    подключил установил драйвер, в программе Ардуино выбрал плату, порт, программатор ArduinoISP.
    написал скетч

    void setup() {
    pinMode(13, OUTPUT);
    }
    void loop() {
    digitalWrite(13, HIGH);
    delay(1000);
    digitalWrite(13, LOW);
    delay(1000);
    }
    после нажатия на "Загрузить"... первая строка текста скетча выделяется розовым цветом, а в нижней части экрана программы написано "Загрузка...", а на черном фоне появляется такой текст:

    ВНИМАНИЕ: Категория '' в библиотеке EEPROM не является действительной. Установка на 'Uncategorized'
    ВНИМАНИЕ: Категория '' в библиотеке SPI не является действительной. Установка на 'Uncategorized'
    ВНИМАНИЕ: Категория '' в библиотеке SoftwareSerial не является действительной. Установка на 'Uncategorized'
    ВНИМАНИЕ: Категория '' в библиотеке Wire не является действительной. Установка на 'Uncategorized'
    Внимание: platform.txt из ядра 'Arduino AVR Boards' содержит устаревшие recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{build.path}/{archive_file}" "{object_file}", автоматически преобразовано в recipe.ar.pattern="{compiler.path}{compiler.ar.cmd}" {compiler.ar.flags} {compiler.ar.extra_flags} "{archive_file_path}" "{object_file}". Ожидайте обновления ядра.

    Скетч использует 1 030 байт (3%) памяти устройства. Всего доступно 32 256 байт.
    Глобальные переменные используют 9 байт (0%) динамической памяти, оставляя 2 039 байт для локальных переменных. Максимум: 2 048 байт.
    processing.app.debug.RunnerException
    at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:179)
    at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
    at processing.app.Sketch.upload(Sketch.java:1187)
    at processing.app.Sketch.exportApplet(Sketch.java:1161)
    at processing.app.Sketch.exportApplet(Sketch.java:1133)
    at processing.app.Editor$DefaultExportHandler.run(Editor.java:2417)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: java.lang.NullPointerException
    at java.lang.String.replace(String.java:2240)
    at processing.app.helpers.StringReplacer.replaceFromMapping(StringReplacer.java:97)
    at processing.app.helpers.StringReplacer.replaceFromMapping(StringReplacer.java:89)
    at processing.app.helpers.StringReplacer.formatAndSplit(StringReplacer.java:37)
    at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:174)
    ... 6 more

    И что мне с этим делать?! Помогите пожалуйста!