Малина - 14

Тема в разделе "Raspberry Pi", создана пользователем Alero, 23 апр 2019.

  1. Alero

    Alero Нерд

    Доброго времени суток.

    При запуске программы в ответ ворчание (скриншот №1).
    На скриншоте №2 результат выполнения установки пакета vk_api.
    Пожалуйста помогите узнать в чем проблема:)
    Ниже текст программы:

    Код (Python):
    # -*- coding: utf-8 -*-
    import time
    import vk_api
    from socket import gethostbyname

    vk = vk_api.VkApi(token = '5f84a31579cb6cd82845b2c8280bc1e1b6df87e6bbc80096c6c5247203b2ce3450435f37435031c661b3c')


    param = {
        'out': 0,
        'cout': 1,
        'time_offset': 5
    }

    def write_msg(user_id, msg):
        vk.method('messages.send', {
            'user_id': user_id,
            'message': msg
            })

    while True:
        response = vk.method('messages.get', param)
        items = response['items']
        if items:
            param['last_message_id'] = items[0]['id']
            for i in items:
                IPAddr = gethostbyname('raspberrypi.local')
                write_msg(i['user_id'], IPAddr)
            time.sleep(1)
    [​IMG]
    [​IMG]
     

    Вложения:

    Последнее редактирование: 24 апр 2019
  2. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    Читаем закреплённое сообщение в разделе и исправляем ошибки
     
    Alero нравится это.
  3. Alero

    Alero Нерд

    Отредактировал в соответствии с правилами.
     
  4. Библиотека установлена для второй версии питона, а редактор ваш работает с третьей, судя по всему.
     
    Alero и BAR__MEN нравится это.
  5. Alero

    Alero Нерд

    угу
    Т.е. либо питон переустанавливать до 2-й версии, либо библиотеку для третьей где искать?
     
  6. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    В raspbian уже установлен python 2.7
     
    Alero нравится это.
  7. ну я бы попробовал настроить редактор на нужную версию питона. или взял другой редактор
     
    Alero нравится это.
  8. Alero

    Alero Нерд

    В терминале, видимо по умолчанию используется последняя версия. Можно ли перенастоить теминал? Или из под 2.7 выполнять скрипт?

    Я запустил 2,7, но запуская скрипт
    вот такое вот ворчание
    [​IMG]
     

    Вложения:

  9. Ну вроде понятно написано. Библиотека неправильно обращается к апи вк, т.к. устарела.
     
  10. Alero

    Alero Нерд

    А может быть, что апи вк устарела?

    Подскажите пожалуйста, где скачать новую. Это наверное надо в терминале команду набрать?
     
  11. апи вк по определению современный
    за новой версией библиотеки к автору библиотеки
     
  12. Alero

    Alero Нерд

    согласен, автору дать яду:)
    т.е. в нашем случае надо расберри пай постоянно "перепрошивать" так? т.е. по сути дороги мои ведут меня на сайт RPi3?
     
  13. если вы собрались работать с вк или любым другим сервисом, обновляться периодически придется
    не знаю, что у вас за дороги, и куда они ведут
     
    Alero нравится это.
  14. Alero

    Alero Нерд

    Извините за дороги:) вы не могли бы кинуть ссылку на мануал и другие полезные линки, касательно обновления требуемых для успешного выплнения задачи библиотек?
     
  15. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    @Alero, обновите библиотеки python с помощью pip: клик
     
    Alero и Daniil нравится это.
  16. Alero

    Alero Нерд

    я пытался по всякому (разные команды пробовал), но ругается постоянно (я понял только, что требуется обновления python 2.7).
    [​IMG]
    [​IMG]
     

    Вложения:

    Последнее редактирование: 25 апр 2019
  17. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    Не pip3, a pip. Библиотека для 2.7, а не для 3
     
  18. Alero

    Alero Нерд

    Прояснилась ситуация. Нужно из терминала запускать (после эентера не надо ждать каких-либо еще сообщений, просто через вк пробовать и да "эхо" есть), тогда программа работает, а из редактора ругается.