Мигание светодиода при включении

Тема в разделе "Arduino & Shields", создана пользователем Den121993, 4 окт 2013.

  1. Den121993

    Den121993 Нуб

    Здравствуйте, подскажите, почему на arduino uno r3 при подключении по usb загорается зеленый светодиод и начинает не переставая мигать желтым цветом светодиод L ? с чем это может быть связано? какие варианты решения могут быть? Заранее благодарен за ответ...
     
  2. roggedhorse

    roggedhorse Гик

    Похоже на предустановленную прошивку Blink
    Вы скетчи уже загружали в эту плату ?
     
  3. urev

    urev Нуб

    С чем может быть связано непрерывное моргание светодиода 13 на arduino nano v3 при подключении к компьютеру, при этом никакого скетча не было, это второе подключение.
    при первом подключении к компьютеру, она определилась, драйвера установились (FTDi), а вот при втором подключении, пишет что драйверов нет и постоянное моргание светодиодом.
    Спасибо!
     
  4. Apofiz

    Apofiz Гик

    Ну дык выб начали с самого начала дуня новая или б.у. что с ней делали до этого?
     
  5. urev

    urev Нуб

    Дуня самая новая, вчера только из магазина!
     
  6. Apofiz

    Apofiz Гик

    Ну дык посмею предположить шо в нее ужо влит скетч Blink вот и мигает сердешный светодиод то.
     
  7. urev

    urev Нуб

    Еще раз: arduino nano куплена вчера, привезена домой, подключаю к ноутбуку, все проходит стандартно, установка драйверов и com6 мой , arduino IDE ее видит, отключаю ее.
    Далее собираю схему (датчики, сервопривод, реле) подключаю к ноутбуку и все ничего не происходит, только моргание 13 светодиода, с периодом примерно 100мс и в диспетчере наблюдаю устройство FTDI232r usb/uart, неопознанное, пытаюсь вручную указать на папку где лежать драйвера, но диспетчер устройств ничего не находит!
    Вот такая картина!
     
  8. SSnick

    SSnick Гик

    Вот именно, в магазе залили бутлоадер и чтобы проверить работоспособность залили блинк и все
     
  9. SSnick

    SSnick Гик

    а что должно происходить то?
     
  10. urev

    urev Нуб

    как минимум должен появиться com порт новый в системе, даже при условии что в магазе в нее залили blink, а он родимый не появляется, вот с эти как справиться?
     
  11. SSnick

    SSnick Гик

    У меня так же бывает, не знаю что причина этому, просто меняю юсб разьем на другой. Бывает, что Уно нормально работает, а нано вые...живается, так нано через другой юсб разьем хорошо работает...
     
  12. Megakoteyka

    Megakoteyka Оракул Модератор

    А покажите схему, которую собираете. Если без схемы работает, то проблема именно в ней.
     
  13. urev

    urev Нуб

    И без схемы тоже самое происходит
     
  14. SSnick

    SSnick Гик

    Вы же сказали, что без периферии все нормально, а с ней нет
     
  15. funyfizik

    funyfizik Нерд

    Честно не понял. Какой скетч заливается? Пример можно? Схему можно?
     
  16. urev

    urev Нуб

    Друзья, представьте себе обычную arduino nano без схемы, без всего чтобы могло быть, подключаю ее кабелем к ноутбуку, а он в ответ определяет устройство FTDI uasb/uart, но не может найти на него драйвера, поэтому arduino IDE ее не определяет.
    Такая ситуация никак не связана со схемой, ибо схемы нет! С arduino ничего до этого не делалось (ежели только в магазине)
    Попытки поменять порт USB ноутбука, поменять кабель, скачать отдельно драйвера ни к чему не привели.
    Пробовал прошивать ее с помощью arduino UNO как ISP программатор и avrdude, в этом случаю прошивка заливается и nano работает (но при этом не определяется компьютером)
    Пытался через ICSP прошить бутлоадер, все прошилось успешно, но результата никакого
     
  17. SSnick

    SSnick Гик

    Обьясни людям нормально, причем тут тогда :
    а потом пишешь:
    или сейчас уже у тебя никак не работает ?

    а второй ардуины у тебя нет? или хотябы атмеги328... подключил вторую, проверил бы.
    А еще лучше проверь на другом компьютере, если там заработает, значит дело в компе
     
  18. urev

    urev Нуб

    Писал об этом
    То есть схема уже не причем, и была не причем, потому как заведомо рабочая, проверено.
    Вторая ардуина есть тоже nano, с ней тоже самое и на этом компьютере и на другом и на третьем, и на XP проверял, осталось только на Ubuntu проверить)
    Хотя Arduino Uno работает без проблем (но у нее другой чип, не FTDI, а CH340)
     
  19. SSnick

    SSnick Гик

    очень странно, две ардуины не работают на всех компах....даж не знаю, что посоветовать, к бабушкам только если сходить....
    может соединяющие провода (кабель) косячный, программатор...
     
  20. urev

    urev Нуб

    есть вариант еще купить и проверить,но бесполезно тратить деньги тоже не вариант...будем думать или довольствоваться прошивкой через icsp