Не удаётся прошить платы esp8266

Тема в разделе "ESP8266, ESP32", создана пользователем Михаил1990, 4 фев 2018.

  1. ИгорьК

    ИгорьК Давно здесь

    Если вы залили ардуино скетч то АТ-КОМАНД быть уже не должно.
     
    yucan нравится это.
  2. ИгорьК

    ИгорьК Давно здесь

    И, есть вероятность, что при прошивке через мс ch340 в плату льется мусор. Вероятность.
     
  3. да, согласен
    Странно, что у многих нет ни каких проблем, подключают, прошивают и все работает, такие же модули такие же ch340(
     
  4. ИгорьК

    ИгорьК Давно здесь

    Да, странно. У меня на одном компе nodemcu шьется а на другом - нет.
     
  5. Airbus

    Airbus Оракул

    Не пролетела я же Вам вчера написал почему.И плата не прошилась.Я раз 20 так Blynk (не путать с Blink)прошивал и не мог понять почему не прошивается.
    А там их нет Вы же затёрли их.Вот возьмите и зажмите Prog со всей силы и не отпускайте пока IDE не остановиться.
     
  6. А там их нет Вы же затёрли их.Вот возьмите и зажмите Prog со всей силы и не отпускайте пока IDE не остановиться.[/QUOTE]

    Пробовал, после того как понял, что не шьется( результат тот же
     
  7. Airbus

    Airbus Оракул

    Может ЭТО поможет?
     
  8. ресет, зажал flash пускаю arduino и ждал пока не закончит заливать (на это раз 6 пин) - пишет загрузка завершена, после чего отпускаю.на 6 пине - 1,перезагружаю плату - мигает 6 пин вместе с синем светодиодом, только с частотой 8 секунд (в программе было выставлено 500мс)
     
  9. ИгорьК

    ИгорьК Давно здесь

    Зажать флаш подать питание потом шить. Я же уже говорил.
     
    Airbus нравится это.
  10. Прошу меня извинить, но похоже у меня руки под одно место заточены, я по глупости указывал не верные пины залил скетч из примера https://geektimes.ru/post/271754/ и все заработало.
    Но остался один вопрос: Почему то на некоторых ногах сидит +3V, а на некоторых меньше 3V?
     
  11. Airbus

    Airbus Оракул

    Получилось?Поздравляю!Что значит "сидит"?И на каких пинах?
     
  12. ИгорьК

    ИгорьК Давно здесь

    Потому что "некоторые пины" имеют внутреннюю подтяжку к питанию по умолчанию а некоторые - нет.
     
  13. Да, получилось. Скетчи заливаются без проблем и держать flash не пришлось.
    "сидит" я имел ввиду, что когда подключаешь к D3, D4, D6 светодиод, то он светится и если замерить напряжение между gnd и соответствующей ногой -3В.

    Потому что "некоторые пины" имеют внутреннюю подтяжку к питанию по умолчанию а некоторые - нет.

    Теперь вроде как разобрался. Спасибо!
     
  14. Различия между ESP8285 и ESP8266
    Поскольку ESP8285 с встроенной 1 Мб флэш-памятью, эквивалентен ESP8266, ESP8285 использует тот же набор SDK, что и ESP8266, а именно ESP8266 SDK. Но по сравнению с ESP8286, ESP8285 имеет следующие отличия:

    • ESP8285 интегрирует 1 Мб Flash в режиме DOUT. В то время как для ESP8266 требуется внешняя флеш память.
    • ESP8285 имеет два дополнительных контакта GPIO (GPIO9 и GPIO10).
    • Для компиляции и загрузки прошивки ESP8285 необходимо установить SPI MODE в режим DOUT, иначе он не сможет работать даже после успешной загрузки.
     
  15. oVoVaN

    oVoVaN Нуб

    мне помогло переустановить драйвер CH341, не с первого раза, к сожалению, но помогло
     
  16. slon-genia

    slon-genia Нуб

    Возникла проблема с прошивкой ESP12E, а точнее с её работой после прошивки. Прошиваю через ARDUINO IDE. Сразу после загрузки скетча ESP начинает выполнять загруженную программу, это при том что GPIO 0 , остаётся быть подключенный к земле. Всё работает до тех пор пока я не отключу питание от ESP и включу снова, при этом не забыв подтянуть GPIO 0 к плюсу питания. После этого программа не отрабатывается- ESP не стартует. Если повторить данную процедуру снова, то всё повторяется. В чом может быть проблема?
     
  17. Это стандартное поведение.
     
  18. slon-genia

    slon-genia Нуб

    В таком случае, как сделать так, чтобы прошивка стартовала? Сам модуль выходит что рабочий, не спалил))). Гуглил очень много, у всех стандартные решения. Подтянул к земле прошил, и убрал от земли. Перед этим стояла прошивка ESP-Link, так та стартовала без проблем.
     
    Последнее редактирование: 10 ноя 2018
  19. slon-genia

    slon-genia Нуб

    При старте или сбросе в терминале пишет вот это:
    ets Jan 8 2013,rst cause:2, boot mode:(1,6)
    Нашёл так же информацию по той строке что привёл выше. В конце параметр boot mode:(1,6) говорит о том, что ESP находится в режиме программирования, а при нормальном старте должно быть что то вроде этого:ets Jan 8 2013,rst cause:2, boot mode:(3,6) . По понятным причинам прошивка не запускается, и это при том, что вывод GPIO 0 подтянут к + 3,3в через резистор, либо весит в воздухе. Значит спалил модуль))) либо ещё что. Не знаю в чём проблема.
     
    Последнее редактирование: 11 ноя 2018