Проблема, компьютер не видит ардуино...

Тема в разделе "Arduino & Shields", создана пользователем Ivan1993, 11 окт 2013.

  1. Usper

    Usper Нерд

    Да, я уже понял, что резистор не нужен, спасибо. Попробовал прошить мегу 16u2, использовав в качестве программатора другую ардуину и, как оказалось, чип помер :(. Впрочем atmega2560 успешно перепрошивается через собственный разъём icsp. А почему вообще мог помереть чип?
     
    Последнее редактирование: 11 июл 2015
  2. Krong

    Krong Нуб

    День добрый.
    Проблема с Mega 2560 R3 [not original]. Операционка Kubuntu 12.04
    Купил свою первую ардуину, несколько дней работала, потом перестала определяться компом при подключении по usb, при этом питание с usb получает, скетч работает.
    Поменял её в магазине.
    Новая платка отработала пару дней и история снова повторилась.
    Не пойму, что происходит, то ли партия плат у них бракованная, толи я что то не так делаю? Можно ли как то её оживить самостоятельно или хотя бы понять что с ней?
     
  3. geher

    geher Гуру

    Похоже на проблему с "левыми" чипами FTDI.
    Это где-то на форуме уже обсуждалось.
    Если же там не FTDI, а как в оригинале, Atmega8U2, то могла прошивка означенного 8U2 "слететь" по какой-нибудь причине.

    Более печальный вариант - FTDI или Atmega8U2 сдох.
     
  4. Krong

    Krong Нуб

    чип у неё ATmega16U2
    купил ещё одну мегу, подключил её к первой, как указано у Ника Гаммона http://www.gammon.com.au/bootloader
    Atmega_Board_Detector показывает что чип жив и бутлоадер в нём прошит Arduino-dfu-usbserial-atmega16u2-Uno-Rev3
    Не понятно тогда, что же в ней слетело.
     
  5. igor_kell

    igor_kell Нуб

    Привет! Купил китайскую ардуинку (комп ее не видит), а у нее нет пинов чтобы сделать ресет перед прошивкой :( может кто-то сталкивался с такой, как ее перепрошить?
     

    Вложения:

    • DSCF7922.jpg
      DSCF7922.jpg
      Размер файла:
      676,3 КБ
      Просмотров:
      741
  6. Airbus

    Airbus Оракул

    Насколько я вижу там FT232?Вся проблема в ней (или в драйверах под Винду кстати какая Винда у Вас?) Перепрошить то сам камень можно только смысл?Там есть 6 пиновый разьём через него можно если дружите с "железом"А с FT232 ничего сделать нельзя она не прошивается.
     
  7. igor_kell

    igor_kell Нуб

    2 микросхемки, которые на ней прицеплены AtmelMega328P и CH340G. Пробовал ставить драйвера для CH340G, все равно выдает "неопознанное усб устройство". Причем ардуинка, в более похожей на оригинал сборке, подключается :(
    win7 ;)
    Можно ли с этим что-то попробовать сделать? или сразу в мусорку? Заранее спасибо за любые советы :)
     
  8. Airbus

    Airbus Оракул

    У меня подобная фигня была (см.Стр 2 темы)Скачал поставил драйвера всё заработало!Драйвер здесь http://tinyurl.com/n9atn3w
     
  9. igor_kell

    igor_kell Нуб

    Не помогло :( и убунту тоже не помогла. Наверное только в мусорку :(
     
  10. Valio

    Valio Нуб

    Купил китайскую ардуино уно, по сути проблема та-же как и с другими китайцами. Значит у меня сначала выдавало ошибку мол нет драйвера на юзб 2.0, потом установил дрова на com порты. Теперь когда вставляю ардуино показывает что драйвер установлен и высвечивается мол вставили com порт usb-serial ch340, но ардуино он не видит. Кто может даст совет?
     
  11. sohat

    sohat Нуб

    Подскажите , пожалуйста.
    Arduino ide не дает выбрать com порт. До переустановки винды такой проблемы не было. В диспетчере устройств порт виден. Правда я дрова китайские ставил через отключение проверки цифровой подписи.
    Поле "порт" - серое и неактивное.
     

    Вложения:

  12. TotCambIKoka

    TotCambIKoka Нерд

    Это с любой ардуино?
    Вероятнее проблема в самой IDE попробуй переустановить
     
  13. Проверь драйвера и посмотри порты!
     
  14. sohat

    sohat Нуб

    С уно и с мегой. А как ее переустановить? она ж portable.
     
  15. Удали сначала папку, а потом зайди в панель потом в программы и компоненты и удали её еще там!
     
  16. Дело может быть не в плате а в сдохших драйверах
     
  17. TotCambIKoka

    TotCambIKoka Нерд

    Алгоритм если не видит какую-то ардуино (нету виртуального ком порта в диспетчере устройств):
    1) проверить кабель... да-да..ну или другой USB порт
    2) вставить другую ардуино: если видит другую - проблема в плате
    3) пробуем переустановить драйвер CH340
    4) если не видит порт в IDE - но есть в диспетчере: переустанавливаем IDE
     
  18. mikiii

    mikiii Нуб

    Товарищи, а у меня сам ARDUINO IDE дал сбой!
    У меня Ardiuno uno 3 поколения (покупал тут) уже как месяцев 5. А IDE на том компе (Windows 7 профессиональная)- меньше месяца:). работал, загружал изменения и тут:
    "сбой загрузки в плату. не найден драйвер com 3.)"
    Думаю - бред, а оказывается у меня ссылка в инструментах порты ARDUINO IDE не видит вообще, даже
    сом 1!!! Тупит точно программа, иначе и мышку комп не видел;), но КАК С ПРОГРАММОЙ!!!!!???????
     
  19. mikiii

    mikiii Нуб

    Эм......

    Само заработало!!:eek::confused:
     
  20. Diki

    Diki Нуб

    Все сделал как написано но у меня никак не загораются последний зелененький огонек (verify) Подскажите пожалуйста как быть дальше!?