Проблема при загрузке скетча на arduino

Тема в разделе "Arduino & Shields", создана пользователем Andronikus, 18 май 2020.

  1. Andronikus

    Andronikus Нуб

    Добрый день, я впервые решил использовать Arduino и выбрал для этого создание автоматической кормушки для животных: по этой ссылке (Делаю самую первую). Все устройства подключил и библиотеки тоже, но при загрузке мне выдает такую ошибку (см. изображение). Подскажите как сделать, чтоб работало (я полный профан в этом вопросе)?
     

    Вложения:

    Последнее редактирование: 20 май 2020
  2. Un_ka

    Un_ka Гик

    Драйвера ставили? COM порт выбирали?
     
  3. NikitOS

    NikitOS Public enemy Администратор

    Файл -> Настройки ->Показать подробный вывод: Компиляция + Загрузка.
    Ошибку в сообщение как код/цитата.
     
  4. b707

    b707 Гуру

    для начала выложить сообщение об ошибке как текст, а не как картинку, на которой ничего невозможно прочитать...
     
    NikitOS нравится это.
  5. Andronikus

    Andronikus Нуб

    Добавил процесс компиляции в текстовом виде
     
  6. Andronikus

    Andronikus Нуб

    Не могли бы вы подсказать как это сделать?
     
  7. akl

    akl Гуру

    вот здесь - пункты 3 и 4. http://wiki.amperka.ru/установка-и-настройка-arduino-ide
    если после подключения к компу в диспетчере устройств ардуина не появляется - значит либо сломан провод либо сама ардуина
    если появляется что-то вроде "неизвестное устройство" или типа того - значит что-то с драйвером

    ну конечно - порт не выбран. См пункт 4 по ссылке выше. ну или если там ничего кроме COM1 нету - значит что-то сломано (провод или ардуина или драйвер)
     
  8. NikitOS

    NikitOS Public enemy Администратор

    Я так понимаю, вставить как код/цитата я кому-то другому сказал?
     
  9. parovoZZ

    parovoZZ Гуру

    до загрузки даже дело не дошло. Может для начала предмет изучить? Ну хотя бы бегло?
     
  10. Andronikus

    Andronikus Нуб

    ну конечно - порт не выбран. См пункт 4 по ссылке выше. ну или если там ничего кроме COM1 нету - значит что-то сломано (провод или ардуина или драйвер)[/QUOTE]
    Я подключаю кабель (обычный от телефона же подойдет?), затем в диспетчере устройств он отображается как просто USB-Device. Проблема в самой плате iskra nano pro?
     
  11. parovoZZ

    parovoZZ Гуру

    нет. Нужен DATA кабель.
     
  12. ZAZ-965

    ZAZ-965 Гуру

    Вы драйвер на CH340 установили? Должно отображаться как USB-SERIAL CH340. Драйвер на китайском сайте производителя CH340 http://www.wch.cn/downloads/file/65.html
     
    SergeiL нравится это.