Проблема с выводом на экран (монитор порта)

Тема в разделе "Arduino & Shields", создана пользователем Dumb, 25 июн 2019.

  1. Dumb

    Dumb Нерд

    Добрый день.
    Помогите решить проблему, плата ардуино нано, пытаюсь вывести что-нибудь на экран, но ардуинка упорно сопротивляется. Пробовал выводить все символы с клавиатуры и все цифры, результат одинаковый, пробовал менять бауд рейт на меньшие и на большие - тоже не помогает. Безымянный.png
     
  2. parovoZZ

    parovoZZ Гуру

    Залей прогу и перевоткни плату. Потом смотри Настройки драйвера ком порта в винде. Ну или сюда скрин кинь.
     
  3. Dumb

    Dumb Нерд

    Залил, перевоткнул. Не совсем понял что ты имел в виду под настройками ком порта, вот скрины. Безымянный1.png Безымянный2.png
     
  4. sslobodyan

    sslobodyan Гик

    Проверь еще настройки самого терминала. Очень похоже на разные скорости обмена. Кстати, системные настройки порта терминальная прога может игнорить и выставлять свои при коннекте.
     
  5. parovoZZ

    parovoZZ Гуру

    Попробуй другой терминалкой и выключи отображение символов.
     
  6. Dumb

    Dumb Нерд

    Попробовал соединиться другим терминалом, вот как отображаются цифры: Безымянный3.png
     
  7. parovoZZ

    parovoZZ Гуру

    нужны именно цифры, а не символы.
     
  8. Asper Daffy

    Asper Daffy Гуру

    А как ты их выводишь?
     
  9. Dumb

    Dumb Нерд

    Так это и есть цифры. Вот я поставил переменный резистор, два боковых вывода кинул на 5V и землю, средний на третий аналоговый пин, выкрутил резистор на ноль, вот что он показывает: Безымянный4.png
    А теперь выкрутил на 200ОМ, вот что теперь: Безымянный5.png
    Значение видно что изменяется, но как будто кодировка не та.
     
  10. parovoZZ

    parovoZZ Гуру

    x - это разве цифра???

    2000М - это что?

    К латинскому алфавиту кодировка не применяется.
     
  11. Dumb

    Dumb Нерд

    Так в том и дело, что ардуинка вместо цифр мне пишет иксы с отзеркаленными знаками вопроса.

    200 Ом это сопротивление переменного резистора который стоит на 5V, земле и А3.
     
  12. KindMan

    KindMan Гик

    Через пару дней откроются новые подробности.
     
    parovoZZ нравится это.
  13. parovoZZ

    parovoZZ Гуру

    Это не ардуина, а терминал интерпретирует числа, которые посылает по интерфейсу ардуина, как символы. Ардуина в душе не чает, что такое символы. Она оперирует ИСКЛЮЧИТЕЛЬНО ЧИСЛАМИ. Поэтому я и прошу выключить отображение символов, а отобразить сигнал с интерфейса "как есть", т.е. в числах.

    а он какое отношение имеет к выводу через терминал???
     
  14. Dumb

    Dumb Нерд

    Как мне выключить в терминале отображение символов?
     
  15. Ariadna-on-Line

    Ariadna-on-Line Гуру

    1. В меню Инструменты - Плата: "Arduino-nano" - стоИт ? А то самая первая картинка - навевает подозрения ?
    2. Вы там не догадались что-нибудь к пинам 0, 1 подключить ? Это - низяяя.
     
    Последнее редактирование: 26 июн 2019
  16. Dumb

    Dumb Нерд

    Конечно стоит, на скринах видно, что написано Arduino Nano на СOM9, к 0 и 1 ничего не подключено.
     
    Последнее редактирование: 26 июн 2019
  17. Ariadna-on-Line

    Ariadna-on-Line Гуру

    1. Кому видно, а кому не очень. Почему же тогда сообщение о Видах-Пидах на первой картинке ?
    2. В программе надо бы всегда указывать источник опорного напряжения для АЦП - analogReference(). Мало ли...
    3. Проверьте напряжение на пине Vref. В справочнике написано сколько там будет. Относительно GND ессно.
     
    Последнее редактирование: 26 июн 2019
  18. parovoZZ

    parovoZZ Гуру

    Терминалке от этой настройки какая печаль?

    http://forum.amperka.ru/threads/Быструю-терминалку-с-отображением-hex-dec.15691/
     
  19. Dumb

    Dumb Нерд

    Вот так? Безымянный6.png

    Безымянный7.png
     
    Последнее редактирование: 26 июн 2019
  20. Ariadna-on-Line

    Ariadna-on-Line Гуру

    А фиг его... Просто когда мне неймется чужой хекс прогнать в Протеусе (макс. скорость его виртуал-терминала 57600), а в хексе скорость заложена больше - я имею кракозябры. Тогда я ставлю скорость виртуал-процессора меньше и смотрю нормальные данные. Может и тута подобное.
    ПС. Не пробовали уменьшить размеры буфера ФИФО ? Там (#3) написано...
     
    Последнее редактирование: 26 июн 2019