Робоняша. Опыт 11 - прилипала (РЕШЕНО)

Тема в разделе "Iskra JS, Espruino, Йодо", создана пользователем Aleksnow, 8 апр 2017.

  1. Aleksnow

    Aleksnow Нерд

    Добрый день.
    На самом деле столкнулся со следующей ситуацией: загружаю скетч для 11 опыта и пока робоняша на проводе все ок, все работает корректно и так как описано в коде) Но как только я пробую автономный режим (т.е. с использованием power bank) робоняша сходит с ума и просто едет вперед.

    Заранее спасибо)
     
    Последнее редактирование: 8 апр 2017
  2. Morgan

    Morgan Administrator Команда форума

    Привет!

    Возможно, разряжен аккумулятор. Попробуйте подзарядить
     
  3. Aleksnow

    Aleksnow Нерд

    Это было первое что я проверил, зарядил до отказа. Сейчас глянул выходное напряжение power bank мультиметром, показал 5v, что достаточно как я понимаю.
     
  4. Morgan

    Morgan Administrator Команда форума

    На плате power bank стоит повышающий преобразователь. Он всегда будет выдавать 5 вольт.
    А вот тока может не хватить, если аккумулятор разряжен. В этом случае при подаче напряжения на двигатели преобразователь не сможет выдать нужную мощность и «просядет» по напряжению. Под просевшим напряжением управляющие платы могут выдавать самые разнообразные эффекты.

    Поставьте на часок хотя бы power bank на зарядку. Если ничего не изменится после этого, подумаем ещё.
     
    arkadyf нравится это.
  5. Aleksnow

    Aleksnow Нерд

    Да я это понимаю. До того как открыть тему попробовал все варианты. Аккум заряжал до отказа. Зарядку брал как в описании, 5v 2.1 А. В итоге результат остался такой же.
     
  6. Aleksnow

    Aleksnow Нерд

    Ещё хотел уточнить что у меня набор робоняша собран не из нового самостоятельного рабора а из набора йода и платформа робоняша (с power bank). Из всех опытов проблема только с теми где используется ультразвуковой дальномер.
     
  7. Morgan

    Morgan Administrator Команда форума

    Может у вас неправильно джамперы стоят на платах? Сверьтесь с картинками из буклета
     
  8. Aleksnow

    Aleksnow Нерд

    Нет. На искре и тройка шилде стоит на 5v, на мотор шилде стоит "join".
     
  9. Morgan

    Morgan Administrator Команда форума

    Можете проверить в консоли что выдаёт дальномер? Судя по всему, там нули должны быть.
     
  10. Aleksnow

    Aleksnow Нерд

    Решение в виде перемычки на vin и 5В, чтобы избавиться от просадки на регуляторе напряжения.
     
    Последнее редактирование: 12 апр 2017
    sys и arkadyf нравится это.
  11. Tvit75

    Tvit75 Нуб

    Доброго времени суток!
    Столкнулся с той же проблемой!
    Прошел тот же путь, от зарядки аккумулятора до проверки напряжения на пинах 8-13.
    скиньте, пожалуйста фото, какая-такая перемычка между vin и 5В? Такой в наборе нет.
     
  12. Aleksnow

    Aleksnow Нерд


    http://wiki.amperka.ru/_media/robot:photo_2017-04-13_18-20-05.jpg
     
    sys и arkadyf нравится это.
  13. Tvit75

    Tvit75 Нуб

  14. SLobatchov

    SLobatchov Нуб

    Та же проблема: при включенном USB робот реагирует как надо, при работе от аккумулятора (полностью заряженного) едет только назад, так как УЗ-датчик видит препятствие на расстоянии 0,5 мм.
    Перемычки на Искре и Тройке стоят в 5В. На мотор шилде - джойн
     
  15. Aleksnow

    Aleksnow Нерд

    http://wiki.amperka.ru/_media/robot:photo_2017-04-13_18-20-05.jpg
     
  16. Aleksnow

    Aleksnow Нерд

    [​IMG]
    Решение идет через костыль) который мне предложила тех. поддержка амперки.