в raspi-config нет i2c и spi

Тема в разделе "Raspberry Pi", создана пользователем proger10, 27 фев 2018.

Метки:
  1. proger10

    proger10 Нуб

    Всем привет!
    Ребята, я что только не пробовал установить и дописать в разные файлы, но ничего не помогло!
    В raspi-config нет А7 вообще, а на месте A6 настройка драйверов!
    Как включить i2c и spi? Снимок.JPG
     
  2. NikitOS

    NikitOS Public enemy Администратор

    raspi-config последний пункт(иле перед ним). Там должно быть
     
  3. proger10

    proger10 Нуб

    что Вы имеете ввиду? можно пожалуйста по конкретней?
    скидываю скрин с raspi-config, последний пункт - информация о малине, предпоследний обновление, не помогла, в advanced options не появились необходимые строчки)

    Снимок.JPG
     
  4. На какой оси вертишь малину? Raspbian, Ubuntu mate или что-то ещё? И какая у тебя модель малины?
     
  5. NikitOS

    NikitOS Public enemy Администратор

    Вопрос непонятный.. Ось скорее всего Raspbian
     
  6. NikitOS

    NikitOS Public enemy Администратор

    Зайдите в пункт 7
     
  7. proger10

    proger10 Нуб

    на Raspbian, модель 2B

    в самом моем первом сообщении с вопросом скрин того, что находится в пункте 7
     
  8. proger10

    proger10 Нуб

    На данный момент в на стройках так и не появилось, но после установления кучи библиотек выдает такое: 2.JPG
    Получается, что i2c работает, но когда выполняю вот эти 2 команды выдает вот что:
    3.JPG
    Не находит подключенный датчик 5.JPG
     

    Вложения:

    • 5.JPG
      5.JPG
      Размер файла:
      30,6 КБ
      Просмотров:
      814
    Последнее редактирование: 27 фев 2018
  9. Igor68

    Igor68 Гуру

    Судя по первой картинке Вы поиск провели с правами ROOT, применив sudo. Далее всё делаете от обычного пользователя. Настройте права доступа... или так же применив sudo.
     
  10. proger10

    proger10 Нуб

    Сделал те же действия со словом sudo, но выдает тоже самое. Странно то, что пишет, что найдено одно оборудование, затем пишет, что нет такого пути /dev/i2c-1, хотя если зайти туда то оно есть, прикрепляю скрин, сам файл i2c-1 пустой, не знаю так и должно быть или нет. 7.JPG