atmega 328ppu + hc-06

Тема в разделе "Микроконтроллеры AVR", создана пользователем iasanov93, 14 авг 2017.

  1. iasanov93

    iasanov93 Нуб

    Здравствуйте, уважаемые обитатели форума, помогите советом.
    В своем проекте я использую блютус модуль hc-06. При подключении его к ардуино уно все работает в штатном режиме, то есть я спокойно подключаюсь к нему и получаю информацию с порта 10 (рх и тх использую не штатные, чтобы не было конфликтов).
    Далее, когда я извлекаю атмегу из ардуино (ну или прошиваю на макетке новую атмегу с заливанием счетча) и размещаю все на макетке, вроде бы, все нормально, то есть блютус и сенсоры работают, но при подключении к блютус я не получаю сигнала.
    Вновь вставляю атмегу в ардуину и все снова работает.
    Подскажите в чем ошибка, почему я не получаю данных с атмегу изымая её из ардуино.
    Пс. Искал по форуму, искал через гугл, не нашёл подобной темы, возможно, даже уверен, что была подобная тема, но по моим ключевым словам не нашёл, простите если так
     
  2. Tomasina

    Tomasina Иномирянин

    что с питанием на макетке?
    Какие там конденсаторы?
     
    BAR__MEN нравится это.
  3. rkit

    rkit Гуру

    Ошибка совершенно очевидно в том, что вы сотворили на макетке. А что вы там сотворили, никому не известно.
     
    iasanov93 и BAR__MEN нравится это.
  4. BAR__MEN

    BAR__MEN Гуру

    Вы бы схему дали!;)
     
  5. iasanov93

    iasanov93 Нуб

    спасибо большое за ответы.

    Питание перекинул с платы ардуино с пина 5в
    Конденсаторов нет никаких, как и резонатора.
    Видел видео, да и у других ребят на форуме ардуино работало без этого всего, подумал тут тоже без этого обойдется.
    Абсолютно согласен, сейчас приложу схему и код.
    Сейчас все приложу :)
    Собственно, схема подключения выглядит так:


    [​IMG]
    В коде задействовал через:
    #include <SoftwareSerial.h>
    SoftwareSerial BT(10, 11);
    #include <avr/io.h>

    А вывод, соответственно, через:
    BT.println(photocellReading);

    вот:( если атмегу вставить в уно всё работает идеально, а когда в макетке отказывается.
    Есть подозрение, что надо в коде ардуино ide сделать запись, что-то типа:

    DDRB = B11111110;
    Но я не уверен в том, что правильно думаю...
    П.с. если есть большие ошибки в макетке не ругайте сильно, я занимаюсь этим делом от силы неделю:)
     
    Последнее редактирование: 14 авг 2017
  6. AlexU

    AlexU Гуру

    В УНО ATmega тактируется от внешнего керамического резонатора на 16 МГц, а на макетке от чего тактируется? Фьюзы поди прошиты так, что бы контроллер от внешнего кварца тактировался или как?
    Синий провод с ноги Reset микроконтроллера на макетке идёт на "пустой" пин УНО. Это Вы так на ногу Reset антенну повесили, что бы побольше помех ловить?
    Судя по приведённой Вами схеме, вообще ни чего не должно работать. С чего Вы взяли, что у Вас "вроде бы, все нормально"?
     
  7. iasanov93

    iasanov93 Нуб


    Да, расчет был на внешний 8МГц резонатор атмеги.
    На счёт ресет, согласен, сделал бред - убрал уже, спасибо.
    С чего взял, что нормально, честно говоря не знаю, модуль блютус вёл себя так же как и при подключении к ардуино, то есть, при простое моргал, при подключении горел индикатор. Видимо, это мне показалось хорошим знаком.
    В таком случае, если в макетку добавить 16МГц кварц, какие ещё необходимо проделать действия?
    Нужно ли именно в коде обращаться к портам МК командами ddr или достаточно будет в скетче описать port13 input?
     
  8. rkit

    rkit Гуру