LXpanel удалена! И другие косяки.

Тема в разделе "Raspberry Pi", создана пользователем krot, 17 июл 2018.

  1. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    А может просто кто-то начал работу без изучения Linux?
    Конечно, привыкли к windows....
     
    Mitrandir нравится это.
  2. krot

    krot Гик

    Так это даже не полноценный Линукс, а его отросток...Джесси.
    Да и в книгах не пишут, что будет, если сделать так :D
     
  3. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    Джесси - это полноценная версия debian. У меня на пк 9 а эта 8
    Почему он не полноценный? Он просо переделан под железо малины
     
  4. krot

    krot Гик

    То, что не могу приложение скомпилировать, непонятные ошибки и Гугл молчит.
    Может дело в версии GCC, но откатываться на старую версию не комильфо.
     
  5. Mitrandir

    Mitrandir Гуру

    Компилятор ругается только на ошибки синтакса, а линкер ( в одном флаконе с компилятором в gcc) ругается на отсутствие библиотеки. Линукс причем тут?
     
    BAR__MEN нравится это.
  6. krot

    krot Гик

    Потому что хз что ему нужно!
    Вот инструкция: https://github.com/EnergyCoinProject/energycoin/blob/master/doc/build-unix.txt
    Вот ошибка: https://prnt.sc/k7vpjt

    Синтаксис соблюден, вся хрень по списку поставлена, либо новая и нифига!
     
  7. AlexU

    AlexU Гуру

    Это проблема с компилятором 'g++'. Проблема связана с неправильной работой с памятью. Кстати, на этом форуме уже обсуждалась аналогичная беда, но с другим компилятором из семейства GCC. Должно решиться установкой более свежей версии GCC.
     
    krot, BAR__MEN и Mitrandir нравится это.
  8. BAR__MEN

    BAR__MEN Вселенский Няш Администратор

    Обновленный GCC!
     
  9. krot

    krot Гик

    А как его установить? Не получается ничего.
     
  10. Mitrandir

    Mitrandir Гуру

    This can be resolved by install GCC 6. Follow these steps :-



    Код (Bash):

    sudo apt-get update
    sudo apt-get upgrade
     
    Next, open /etc/apt/sources.list in your favorite editor and repalce jessie with stretch:

    Код (Bash):

    sudo vim /etc/apt/sources.list
     
    Update your package list:

    Код (Bash):

    sudo apt-get update
     
    Install GCC 6
    Код (Bash):

    sudo apt-get install gcc-6 g++-6
     
    Last step is to revert back from Stretch to Jessie, open /etc/apt/sources.list and replace stretch with jessie, after that do an update to refresh the package list:


    sudo vim /etc/apt/sources.list
    sudo apt-get update

    The above procedure will keep GCC 4.9 as the default C and C++ compiler for any package that depends on it, if you want to compile a program with GCC 6 you will have to use gcc-6 or g++-6 when invoking the compilers.

    In GCC 6 the default C++ standard is now -std=gnu++14, which means that by default any C++ program will be treated as a C++14. For C, the default is std=gnu11 starting from GCC 5.
     
  11. krot

    krot Гик

    А может все беды из-за ОСи Джесси?
    Если поставить последний Скретч, там же должны быть по идее последние все эти библиотеки и прочее?
     
  12. krot

    krot Гик

    sudo: vim: command not found
    началось........:oops:
     
  13. Mitrandir

    Mitrandir Гуру

    Или установите vim или замените его на тот редактор что есть
     
  14. krot

    krot Гик

    у меня mc стоит
     
  15. Mitrandir

    Mitrandir Гуру

    MC это файловый менеджер
    Vim текстовый редактор

    Попробуйте nano вместо vim он вроде из коробки стоит
     
  16. krot

    krot Гик

    А как файл потом пересохранять?
    Я убрал значок # и нифига.
     
  17. Mitrandir

    Mitrandir Гуру

    В каком редакторе?
    В нано контрл у он спросит сохранить или нет
    В вим ескейп затем !w
     
  18. krot

    krot Гик

    Не понимаю(
    http://prntscr.com/k8baeh

    W10: Предупреждение: Изменение файла с правами только для чтения
     
  19. Mitrandir

    Mitrandir Гуру

    Поставьте нано.
    Вим очень мощный редактор, но в него тяжело вникнуть.
     
    parovoZZ нравится это.
  20. krot

    krot Гик

    Так я не понимаю что именно правлю и зачем....
    Команда sudoapt-get install gcc-6 g++-6 ничего не находит, и не ставит.

    http://prntscr.com/k8bdfg
    Что тут править?