Raspberry pi пакет flask не может установить

Тема в разделе "Raspberry Pi", создана пользователем Gen, 13 июл 2019.

Метки:
  1. Gen

    Gen Нуб

    В командной строке чтобы установить пакет flask я пишу sudo apt-get install python-flask, но он выдаёт ошибку:

    E: Работа dpkg прервана, вы должны вручную запустить “sudo dpkg - -configure -a” для установки проблемы.
     
  2. BAR__MEN

    BAR__MEN Вселенский Няш Команда форума

    Hi!
    Сделайте то, что просит система, выполните команду:
    Код (Text):
    sudo dpkg --configure -a
     
  3. Gen

    Gen Нуб

    Как это сделать
     
  4. BAR__MEN

    BAR__MEN Вселенский Няш Команда форума

    Открыть терминал и выполнить команду...:confused:
     
  5. Gen

    Gen Нуб

    Я написал это и повторил команду и теперь он мне выдаёт:
    Чтение списков пакетов... Ошибка!
    E: Problem parsing dependency 20
    E: Произошла ошибка во время обработки python-bibtexparser (NewVersion2)
    E: Problem with Mergelist /bar/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages
    E: Списки пакетов или файл состояния не могут быть открыты или прочитаны.
     
    Последнее редактирование: 13 июл 2019
  6. BAR__MEN

    BAR__MEN Вселенский Няш Команда форума

    И нажать Enter...
     
  7. Gen

    Gen Нуб

    Я написал это и повторил команду и теперь он мне выдаёт:
    Чтение списков пакетов... Ошибка!
    E: Problem parsing dependency 20
    E: Произошла ошибка во время обработки python-bibtexparser (NewVersion2)
    E: Problem with Mergelist /bar/lib/apt/lists/raspbian.raspberrypi.org_raspbian_dists_stretch_main_binary-armhf_Packages
    E: Списки пакетов или файл состояния не могут быть открыты или прочитаны
     
  8. ZAZ-965

    ZAZ-965 Гуру

    Попробуйте удалить все загруженные списки пакетов и обновить базу пакетов
    Код (Bash):
    sudo rm /var/lib/apt/lists/* -f
    sudo apt-get update
     
  9. Gen

    Gen Нуб

    Все ровно ошибка
     
  10. ZAZ-965

    ZAZ-965 Гуру

    Ошибка та же? Попробуйте сперва очистить локальный кэш пакетов
    Код (Bash):
    sudo apt-get clean
     
  11. Gen

    Gen Нуб

    Я все сделал но он все ровно пишет ошибка E: Пакет libreoffice-systray нуждается в переустановке, но найти архив для него не удалось.
     
  12. ZAZ-965

    ZAZ-965 Гуру

    Повторите всё последовательно
    Код (Bash):
    sudo apt-get clean
    sudo rm /var/lib/apt/lists/* -f
    sudo apt-get update
    sudo dpkg --configure -a
     
    BAR__MEN нравится это.
  13. Gen

    Gen Нуб

    Ошибка
     
  14. BAR__MEN

    BAR__MEN Вселенский Няш Команда форума

    А ошибка-то какая?