UNO: нет напряжения на пинах

Тема в разделе "Arduino & Shields", создана пользователем dkurtaev, 31 дек 2017.

  1. dkurtaev

    dkurtaev Нуб

    Видимых повреждений на плате нет. Индикаторы зажигаются в нужном порядке. Скетчи заливаются и перезапускаются по нажатию кнопки. Но ни пины постоянного напряжения, ни контролируемые пины не работают :(

    Как бы наивно не звучало, перестала работать однажды. Был, конечно, момент, когда работающую плату помещал на поверхность руки, от чего та нагревалась. Но проблем с работой не было после этого.

    Не понятно, почему нет видимых последствий. Или можно "спалить" плату неявно? Прошу поделиться опытом поломок.
     

    Вложения:

    • P1070396.JPG
      P1070396.JPG
      Размер файла:
      208,1 КБ
      Просмотров:
      456
    • P1070397.JPG
      P1070397.JPG
      Размер файла:
      228,2 КБ
      Просмотров:
      327
    • P1070398.JPG
      P1070398.JPG
      Размер файла:
      189,3 КБ
      Просмотров:
      343
    • P1070399.JPG
      P1070399.JPG
      Размер файла:
      151,1 КБ
      Просмотров:
      613
  2. Airbus

    Airbus Радиохулиган Модератор

    Blink блинкает?
     
  3. dkurtaev

    dkurtaev Нуб

    Если Вы об этом, да, мигает:
    Код (C++):
    void setup() {
      pinMode(13, OUTPUT);
    }

    void loop() {
      digitalWrite(13, HIGH);
      delay(1000);
      digitalWrite(13, LOW);
      delay(1000);
    }
     
  4. Airbus

    Airbus Радиохулиган Модератор

    Тогда в чём проблема?
     
  5. dkurtaev

    dkurtaev Нуб

    Да маловато будет одного встроенного светодиода :) При подключении светодиода внешнего к 5V - не зажигается. При работе с пинами 0-12 та же проблема.
     
  6. Airbus

    Airbus Радиохулиган Модератор

    Светодиоды правильно включаете?Проверьте полярность.Спалить все порты практически нереально но можно.При этом микросхема раскаляется докрасна и воняет.
     
    dkurtaev нравится это.
  7. CYITEP_BAC9I

    CYITEP_BAC9I Гик

    главное что бы из микросхемы не вышел волшебный дым). если выйдет то все.
    С новым годом!
     
    NikitOS и dkurtaev нравится это.
  8. akl

    akl Гуру

    может светодиод мертвый? если его к 13 пину подключить - он мигает вместе со встроенным?

    да еще так чтобы даже на Vin пропало напряжение. вангую что либо светодид умер, либо подключается неправильно
     
    dkurtaev и CYITEP_BAC9I нравится это.
  9. dkurtaev

    dkurtaev Нуб

    На фотографиях попытался показать, что при той же схеме работает от батарейки, но ни подключении в 5V + GND ноль эмоций.
    Это-то и не нравится больше всего, что дыма не было, а работать не хочет))
    С новым счастьем! =)
     
  10. akl

    akl Гуру

    может я что-то путаю, но мне кажется у батарейки таблетошной плоская верхушка (что с письменами) это + :oops:
     
    dkurtaev и CYITEP_BAC9I нравится это.
  11. dkurtaev

    dkurtaev Нуб

    Жесть. Вот позор-то. Всё в порядке, получается. Перепутал ножки. Всё заработало как надо. Спасибо большое!))
     
  12. Airbus

    Airbus Радиохулиган Модератор

    Look Sharp!:cool:
     
    dkurtaev нравится это.
  13. Igor68

    Igor68 Гуру

    Ну Вы блин даёте! С Новым Годом!
     
    NikitOS и dkurtaev нравится это.