ESPlorer не видит плату - что делать?

Тема в разделе "ESP8266, ESP32", создана пользователем ИгорьК, 12 янв 2018.

Метки:
  1. ИгорьК

    ИгорьК Давно здесь

    В последней версии Windows10 ESplorer перестал видеть платы на чипах CP2102 и CH(...)
    Это касается, в первую очередь, модулей NodeMCU и новых ESP32.
    На вопрос о проблеме, разработчик ответил следующее:

    upload_2018-1-12_10-33-4.png

    Что с этим можно делать?

    1. Коннектиться к плате через соответствующие ножки через PL2303 - ESPlorer плату видит.
    upload_2018-1-12_10-40-15.png
    2. Переходить на ESCut:

    upload_2018-1-12_10-35-52.png

    Чуть менее удобен ESPLoer(a), нет сниппетов. В остальном - то же самое.
     
    Последнее редактирование: 12 янв 2018
  2. gofk

    gofk Нерд

    И нет версии под MacOS, хотя там и с ESPlorer проблем нет пока.
     
  3. ИгорьК

    ИгорьК Давно здесь

    Проблема выявлена в последних версиях Windows10.
    У меня как-то совпало - перепрошил модуль NodeMCU, и оставил не проверив. Через день-два включаю - не работает, плата определяется, ESPlorer порт видит но не коннектится. Сколько же я времени убил в прошивках... Плата шьется, но не подключается.
     
  4. Airbus

    Airbus Оракул

    Старые шнурки от старых Мабил.Там как раз PL2303
     
    Последнее редактирование: 12 янв 2018
  5. ИгорьК

    ИгорьК Давно здесь

  6. Airbus

    Airbus Оракул

    Да можно если надо.В Евросетях в пыльных ящиках рублей за 50.На Авито.Итд
     
  7. Airbus

    Airbus Оракул

    У меня другая беда.Всё работало скрипты загружались.Ничего не трогал 2 месяца.Сегодня решил потренироваться.И получил сюрприз!Мало того что плата конектиться только на 115200 (а раньше и на 9600)теперь при загрузкt скрипта выдает ошибки пишет ERROR в каждой строчке.В чём косяк?
    Простой принт
    [​IMG]
    Или init.lua
    [​IMG]
    Прошивка v0.9.5.2 AT Firmware
     
  8. ИгорьК

    ИгорьК Давно здесь

    АТ - а при чем здесь Lua? Или я что-то не понял?
     
  9. Airbus

    Airbus Оракул

    Попытаюсь объяснить понятнее-прошивка v0.9.5.2 AT Firmware из комплекта Node MCU Flasher та прошивка которой плата прошита с Завода. Потом я прошил Телеграммом из Ардуино IDE и сейчас решил всё вернуть "как было" чтобы поучиться писать скрипты на LUA. Для этого вернул "родную" прошивку. Делал всё как написано. Или я что то не догоняю?
     
  10. ИгорьК

    ИгорьК Давно здесь

    дайте ей в терминале команду
    Код (C++):
    AT
     
    Airbus нравится это.
  11. ИгорьК

    ИгорьК Давно здесь

    Airbus нравится это.
  12. Airbus

    Airbus Оракул

    На АТ команды отвечает.Собрать тоже можно но это долго и нудно да и не знаю под что собирать.А что 0.9.5 это старьё и не должна работать?
     
  13. ИгорьК

    ИгорьК Давно здесь

    Это не Lua прошивка. Это просто не Lua прошивка и она не будет отвечать на те вещи, что вы ей отправляете.

    Вот Lua прошивка одна из последних.
     

    Вложения:

    Airbus нравится это.
  14. ИгорьК

    ИгорьК Давно здесь

    Вложения:

    Airbus нравится это.
  15. Airbus

    Airbus Оракул

    То есть если я правильно понял то кроме самой прошивки (коей вполне может быть и nodemcu_integer_0.9.5_20150318.bin упомянутая мной в начале) с адреса 0х00000 надо прошить ещё и esp_init_data_default.bin по адресу 0x3FC000 в моём случае?Я же прошивал только nodemcu_integer_0.9.5_20150318.bin и видимо в этом причина?
     
  16. Airbus

    Airbus Оракул

    Всё понял!Прошил два бинарика зараз и всё заработало!Спасибо Игорь!
     
  17. ИгорьК

    ИгорьК Давно здесь

    Нет. Прошивка init нужна лишь тогда, когда модуль "сходит с ума" выдачей в порт всякого бреда.